二维码
搬瓦工 locvps

LNMP一键安装包下存在跨站和跨目录的问题,跨站和跨目录影响同服务器/VPS上的其他网站,最近看PHP 5.3,在5.3.3以上已经增加了HOST配置,可以起到防跨站、跨目录的问题。

如果你是PHP 5.3.3以上的版本,可以修改/usr/local/php/etc/php.ini在末尾里加入:

[HOST=www.vpskp.com] open_basedir=/home/wwwroot/www.vpskp.com/:/tmp/
[PATH=/home/wwwroot/www.vpskp.com] open_basedir=/home/wwwroot/www.vpskp.com/:/tmp/


按上面的这个例子修改,换成你自己的域名和目录,多个网站就按上面的例子改成多个,最后重启php-fpm:/etc/init.d/php-fpm restart

如果让网站可以使用探针需要在/tmp/后加上:/proc/

PHP 5.3.3以上版本的用户,(LNMP 1.0以上默认已支持,不需要要替换)可以执行:cd /root;rm -f /root/vhost.sh;wget http://soft.vpskp.com/lnmp/ext/vhost.sh;chmod +x /root/vhost.sh,这样替换原来的vhost.sh文件,以后添加网站就会自动添加HOST防跨站、跨目录的配置。

为解决升级PHP 5.3.*版本后部分需要PHP 5.2.*版本的程序无法运行的问题,我们会增加一个PHP 5.2的安装脚本,脚本将在未来几天发布。

注意:open_basedir 不是万能的也不是绝对安全的,会阻止一部分防跨目录的行为,但是同时也存在很多绕过open_basedir的方法。


locvps
评论专区
  • 昵 称必填
  • 邮 箱必填
  • 网 址选填
◎已有 0 人评论
BudgetVM
作者介绍
转载大师

转载大师

转载大师作为本站编辑,主要负责把优秀的文章转载至此。如果您认为本文侵犯了您的版权信息,请与转载大师联系修正。
80vps henghost
budgetvm sugarhosts
二维码

分享:

支付宝

微信