二维码
搬瓦工 locvps

由于PHP7.X版本对于WordPress程序效率得到不错的提升,我也陆续将服务器都升级至7.0或者7.1版本PHP,但是今天发现一个问题,服务器中的zblog PHP程序在PHP7.1环境中编辑、修改文章的时候有出现错误,提示"[] operator not supported for strings"错误提示。

以上是点击编辑文章时候出现的错误,然后去ZBP老板那边去问问如何解决,应该是PHP7.1数组格式问题。

解决方法:

zb_system/functiON/lib/post.php

找到这个文件,第63行。

将:

$c = '';

改为

$c =array();

最后,我们再去ZBLOG PHP后台编辑需要的文章就不会有错误。

locvps
评论专区
  • 昵 称必填
  • 邮 箱必填
  • 网 址选填
◎已有 0 人评论
BudgetVM
作者介绍
总干事

总干事

总干事作为本站编辑,主要负责VPS优惠、域名优惠和站长百科三个栏目。
80vps henghost
budgetvm sugarhosts
二维码

分享:

支付宝

微信