二维码
搬瓦工 locvps

目前,WordPress程序最新版本是4.9.6,增加了隐私政策功能。一般我们正常的升级是没有问题的,不过今天早上有一个公司客户企业网站好像有点问题。前端正常,但是在打开后台的时候有出现错误,无法看到后台登录界面。

Warning: call_user_func_array() expects parameter 1 to be a valid callback, functiON 'wp_schedule_delete_old_privacy_export_files' not found or invalid function name in ****\wp-includes\class-wp-hook.php on line 286

Fatal error: Call to undefined function wp_privacy_anonymize_ip() in ***\wp-admin\includes\class-wp-community-events.php on line 267

解决WordPress出现"call_user_func_array() expects"错误

从报错看,应该是新版本可能与PHP兼容报错问题,因为这个服务器WEB环境一直没有升级,还是早期的PHP5.2,这个确实有点陈旧。要么升级PHP,要么就临时解决关闭报错。

解决WordPress出现"call_user_func_array() expects"错误

这里在php.ini文件中,将display_errors报错提醒修改成OFF,然后重启PHP之后,我们再看看就可以解决这个问题。


locvps
评论专区
  • 昵 称必填
  • 邮 箱必填
  • 网 址选填
◎已有 0 人评论
BudgetVM
作者介绍
转载大师

转载大师

转载大师作为本站编辑,主要负责把优秀的文章转载至此。如果您认为本文侵犯了您的版权信息,请与转载大师联系修正。
80vps henghost
budgetvm sugarhosts
二维码

分享:

支付宝

微信